Commit 076b7a17 authored by Mike Wey's avatar Mike Wey
Browse files

Update the changelog and the version number.

parent cd12782f
GtkD ChangeLog
==============
Release: 3.6.0
--------------
-Update the libraries to the latest versions.
-Add librsvg. #193
-Allow for not using the runtime linker when generating the binding.
-Add mixin templates to generate the boilerplate needed to implement Gtk interfaces
or overrideing Gtk functions.
Release: 3.5.1
--------------
- Set the correct path for the pkgconfig files. #181
-Set the correct path for the pkgconfig files. #181
Release: 3.5.0
--------------
......
......@@ -59,7 +59,7 @@ RANLIB=ranlib
#######################################################################
GTKD_VERSION=3.5.1
GTKD_VERSION=3.6.0
SO_VERSION=0
MAJOR = $(word 1,$(subst ., ,$(GTKD_VERSION)))
......
......@@ -16,12 +16,12 @@
"hauptmech"
],
"dependencies": {
"gtk-d:gtkdgl": "~>3.5.0",
"gtk-d:sv": "~>3.5.0",
"gtk-d:vte": "~>3.5.0",
"gtk-d:gtkd": "~>3.5.0",
"gtk-d:gstreamer": "~>3.5.0",
"gtk-d:peas": "~>3.5.0"
"gtk-d:gtkdgl": "~>3.6.0",
"gtk-d:sv": "~>3.6.0",
"gtk-d:vte": "~>3.6.0",
"gtk-d:gtkd": "~>3.6.0",
"gtk-d:gstreamer": "~>3.6.0",
"gtk-d:peas": "~>3.6.0"
},
"subPackages" : [
......@@ -40,7 +40,7 @@
"sourcePaths": ["generated/gtkdgl"],
"libs-posix": ["dl"],
"importPaths": ["generated/gtkdgl"],
"dependencies": {"gtk-d:gtkd":"~>3.5.0"}
"dependencies": {"gtk-d:gtkd":"~>3.6.0"}
},
{
"name": "sv",
......@@ -49,7 +49,7 @@
"sourcePaths": ["generated/sourceview"],
"libs-posix": ["dl"],
"importPaths": ["generated/sourceview"],
"dependencies": {"gtk-d:gtkd":"~>3.5.0"}
"dependencies": {"gtk-d:gtkd":"~>3.6.0"}
},
{
"name": "gstreamer",
......@@ -58,7 +58,7 @@
"sourcePaths": ["generated/gstreamer"],
"libs-posix": ["dl"],
"importPaths": ["generated/gstreamer"],
"dependencies": {"gtk-d:gtkd":"~>3.5.0"}
"dependencies": {"gtk-d:gtkd":"~>3.6.0"}
},
{
"name": "vte",
......@@ -67,7 +67,7 @@
"sourcePaths": ["generated/vte"],
"libs-posix": ["dl"],
"importPaths": ["generated/vte"],
"dependencies": {"gtk-d:gtkd":"~>3.5.0"}
"dependencies": {"gtk-d:gtkd":"~>3.6.0"}
},
{
"name": "peas",
......@@ -76,7 +76,7 @@
"sourcePaths": ["generated/peas"],
"libs-posix": ["dl"],
"importPaths": ["generated/peas"],
"dependencies": {"gtk-d:gtkd":"~>3.5.0"}
"dependencies": {"gtk-d:gtkd":"~>3.6.0"}
}
]
}
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment